Super Wingpanel el nuevo panel para elementary OS

La evolución para Wingpanel y Wingpanel Slim, se llama Super Wingpanel. Un nuevo panel para elementary OS que esta formado por ambos componentes y que además incluye muchas de las mejoras esperadas por todos los usuarios de este SO.

Super Wingpanel el nuevo panel para elementary OS

Continuamos teniendo de momento los dos anteriores, a seleccionar y configurar todo, a través de Preferencias del sistema, conforme el modulo Tweaks (elementary-tweaks) que deberemos de tener previamente instalado. Y que también ha sufrido cambios, disponiendo ahora de una nueva entrada, llamada Super Wingpanel y que emplearemos para configurar todos los nuevos parámetros de este nuevo panel.

Preferencias del sistema

Sus características son las siguientes:

Super Wingpanel

Con esto activamos o no el uso de Super Wingpanel, de tenerlo activo se desactivara de forma automática cualquier otro de los anteriores que tuviéramos.

Modo de ocultación

Dispone de cuatro modos y van a reflejar el comportamiento del panel en el escritorio respecto a su relación con las ventanas.

  • Never Hide: Utilizará el panel largo o el corto, conforme el resto de parámetros y permanecerá siempre visible.
  • IntelliHide: Se ocultará solamente cuando tengamos la ventana maximizada.
  • Intellislim: Opción por defecto, utiliza ambos paneles. Pasando del largo al corto, dependiendo si tenemos la ventana o no maximizada.
  • AutoHide: Siempre permanecerá oculta, mostrándose por la presencia del ratón.

Show windows Control

De tenerlo activo, mostrara los botones de cierre y maximizar, cuando la ventana actual se encuentre maximizada. Solo disponible para el panel largo.

Show Control

Mostrar el lanzador

Permite activar o desactivar la presencia del lanzador del Menú en el panel.

Launcher Text Override

El literal por defecto que muestra el lanzador es Aplicaciones, aquí podemos definir cualquier otro literal que deseemos que aparezca.

Lanzador

El lanzador a utilizar por defecto, deberemos tener slingshot-launcher

Slim Mode

Permite activar o desactivar el modo Slim, es decir el panel corto.

Separate Launcher

Nos permite activar el poder separar el lanzador del panel, esto solamente funcionara en modo Slim o panel corto.

Borde

Diferentes de estilos a usar por el modo Slim y continuamos teniendo:

  • Inclinado
  • Cuadrado
  • Curvo 1
  • Curvo 2
  • Curvo 3

Posición

Posiciones para utilizar por el modo Slim y sigue disponiendo de:

  • Derecha
  • Central
  • Izquierda
  • Nivelar a la izquierda
  • Nivelar a la derecha

Margen

Distancia a utilizar respecto al borde, a utilizar solamente para las posiciones Derecha e Izquierda.

Posicionamiento y orden de los indicadores

Anteriormente, el orden de los indicadores que se mostraban era fija. Ahora con este Super Wingpanel, podemos establecer el orden que deseemos para nuestros indicadores. Actualmente no disponible desde Tweaks (elementary-tweaks). Por lo que deberemos de utilizar por el momento dconf Editor

Configuration Editor

Donde iremos cortando y pegando la librerias de los indicadores, de izquierda a derecha en la posición que deseemos. Una opción que se antoja algo complicada para usuarios todavia poco experimentados, por lo que es mas que recomendable esperar a la finalización del desarrollo que se deberá de realizar en Tweaks (elementary-tweaks)

Disposición fija

Fija

Disposición personalizada

Personalizada

Instalación

Disponible desde los repositorios de elementary para sus actualizaciones y daily. A falta como hemos visto de ciertos retoques. Aunque hay que decir que el panel en todo momento se ha comportado y a funcionado correctamente.

Para aquellos que no puedan esperar más para uso, os indico como sería su instalación actual y actualización de paquetes requeridos. Desde la consola.

$ sudo add-apt-repository ppa:versable/elementary-update
$ sudo add-apt-repository ppa:elementary-os/daily
$ sudo apt-get update
$ sudo apt-get install super-wingpanel elementary-tweaks slingshot-launcher

Si todavía no tuvieras instalado dconf Editor.

$ sudo apt-get install dconf-tools

Si no quisieras recibir actualizaciones de estos repositorios por la posible inestabilidad de los paquetes.

$ sudo add-apt-repository -r ppa:versable/elementary-update
$ sudo add-apt-repository -r ppa:elementary-os/daily
$ sudo apt-get update

 

Esta entrada fue publicada en articulo, elementaryos, GNU/Linux y etiquetada , , , . Guarda el enlace permanente.

21 respuestas a Super Wingpanel el nuevo panel para elementary OS

  1. CamiloM dijo:

    Hola, maravilloso post, quisiera saber como ponen transparencias en slingshot-launcher, gracias

  2. Ignacio dijo:

    Hola, hay manera de añadir otro menú. Por ejemplo tener Aplicaciones y a un lado, Lugares como hay en gnome-classic? http://www.omgubuntu.co.uk/wp-content/uploads/2012/03/menus.jpg

  3. Hola Que tal, excelente post, no termine de leerlo cuando ya lo había instalado y personalizado jeje, oye una pregunta, con el Wingpanel Slim, podia poner mi nombre de usuario en el panel, tienes idea de como se hace pero en este Super Wingpanel?

    • yunn dijo:

      Hola Eder Valencia, bueno en un principio esto si te funcionaba con Wingpanel Slim, te debería funcionar tambien con Super Wingpanel, ya que digamos es una funcionalidad más de ubuntu que de elementary OS, a mi me esta funcionando perfectamente. Te recuerdo como era esto, para activarlo:

      $ gsettings set com.canonical.indicator.session show-real-name-on-panel true && killall super-wingpanel

      para desactivarlo,

      $ gsettings set com.canonical.indicator.session show-real-name-on-panel false && killall super-wingpanel

      Saludos,

  4. Muchas gracias por el aporte, cada vez me siento mas a gusto con esta distro, jejeje me encontre con este blog por accidente, me siento muchas veces tentado a cambiar por deepin o algo mas pero parece que hay algo que quizas otras distro no tienen es la estabilidad, gracias amigo

  5. DemianTux dijo:

    Buenas Yunn! Es posible instalarlo para Freya? Ahora con la nueva versión aún me gusta más elementary y me encantarí disfrutar de esta característica, pero no quiero instalar que pueda alterar el sistema.

    Gracias!

    • yunn dijo:

      Hola DemianTux, pues no es recomendable su instalación, habra que esperar que realicen los cambios necesarios para su funcionamiento correcto. Esperemos que con el tiempo, alguien realice este desarrollo. Estaré pendiente. Saludos,

  6. Iñaki dijo:

    Hola cuando pongo el comando install super-wingpanel me dice que no se ha podido localizar el paquete

    • yunn dijo:

      Hola Iñaki, super-wingpanel solamente funciona en Luna, si es Luna la que estas utililzando, revisa de nuevo si has incluido correctamente el repositorio ya que esa PPA a pesar del tiempo y de momento, parece que sigue funcionando. Saludos,

  7. Diego Lara dijo:

    Algo parecido que funcione en Loki?

  8. javier dijo:

    Hola…

    Solicito su ayuda ya que he intentado y no me deja instalar super wing panel, al darle update me sale el siguiente error:
    Err http://ppa.launchpad.net trusty/main amd64 Packages
    404 Not Found
    Err http://ppa.launchpad.net trusty/main i386 Packages
    404 Not Found
    Ign http://ppa.launchpad.net trusty/main Translation-es_ES
    Ign http://ppa.launchpad.net trusty/main Translation-es
    Ign http://ppa.launchpad.net trusty/main Translation-en
    Descargados 97.9 kB en 35seg. (2 764 B/s)
    W: Imposible obtener http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found

    W: Imposible obtener http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found

    E: Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar

    Y si aun asi le doy install super-wingpanel me sale el siguiente error:

    Los siguientes paquetes tienen dependencias incumplidas:
    super-wingpanel : Depende: libgranite1 (>= 0.2.0~) pero no es instalable
    Recomienda: indicator-me pero no es instalable
    E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

    Me gustaria me apoyaran con este tema, soy nuevo en este linux.
    Gracias de antemano por su ayuda.

    • yunn dijo:

      Hola Javier, este post es de al menos dos años…y a la versión a la que se refiere es para elementary Luna y tu la versión que tienes se corresponde con elementary Freya, versión que es incompatible con Super Wingpanel. Por tanto te recomiendo que borres esos repositorios con,

      $ sudo add-apt-repository -r ppa:versable/elementary-update
      $ sudo add-apt-repository -r ppa:elementary-os/daily
      $ sudo apt-get update

      Saludos,

      • javier dijo:

        Ok gracias por tu respuesta, y asi es tengo freya. Lastima se veia muy bien y queria usuarla, ni modos.

        Gracias de nuevo

  9. Omar dijo:

    Disculpa si desapareció de mi elementary os loki lo puedo volver a instalar?

Deja un comentario