¿ Algún problema con elementary Tweaks ?

Muchos usuarios viven al límite en cuanto a sus repositorios disponibles, a pesar de que algunos de ellos son para programas que actualmente están en desarrollo, por tanto inacabados, o se encuentran pendientes de testing.

Ese es el caso por ejemplo de la PPA para elementary Daily.

Algún problema con elementary Tweaks

Donde elementary OS tiene, principalmente todos sus proyectos nuevos, así como aquellos sensibles de ser mejorados.

La ventaja de tener este repositorio está, en disfrutar del software anticipadamente y por inconveniente, que los cambios de programas y librerías pueden afectar, a los ya existentes en el sistema, pudiendo muchos de ellos dejar de funcionar.

Error elementary tweaks

Ese es el caso de elementary Tweaks, actualmente totalmente inutilizable.

¿ Cual es la solución ? Bueno, su solución pasa por esperar a su actualización y que su funcionalidad este terminada y que funcione correctamente. O bien, pasar a una versión anterior de cuando funcionaba.

Como su actualización no llega, mejor pasamos a realizar la segunda opción. El problema principal consiste en averiguar, que es lo que se ha actualizado, programas, librerías, etc… que finalmente le ha afectado. Para averiguar toda esta información, podemos utilizar nuestro veterano gestor de paquetes Synaptic.

Synaptic

Si accedemos a las propiedades del paquetes  y seleccionamos la pestaña de dependencias,

Propiedades

tenemos toda la lista de posibles candidatos que de una manera u otra pueden afectar a elementary Tweaks.

Si de todo esto descartamos, todo aquello que no se encuentra en la Daily de elementary, al final, la lista se ve muy reducida a un par de librerías, que tras investigar un poco finalmente se trata de libgranite1. Que si miramos en sus propiedades,

Propiedades libgranite1

pestaña de versiones, veremos todas las actualizaciones recibidas con su número de versión correspondiente.

Propiedades libgranite1 versiones

Muy oportuna y bien situada, está una nota con la indicaciones de como instalar, cualquiera de las versiones que ha recibido el sistema. Procedemos por tanto con esto,

Forzar version

seleccionando una versión anterior a la actual,

Forzar version seleccion

y aplicamos los cambios,

Aplicar cambios

por lo que hasta aquí, ya tendríamos resuelto el problema.

Ahora tendremos que resolver el problema que tendríamos con las actualizaciones futuras, en especial con la versión del paquete libgranite1 que no esta bien. Para evitar que en las siguientes actualizaciones, se nos vuelva a instalar este paquete. Para eso creamos el archivo preferences en la carpeta /etc/apt, donde indicaremos que paquete tiene mayor prioridad indicando en este caso el repositorio estable en vez del daily.

Preferences

El texto a insertar sería el siguiente.

Package: libgranite1
Pin: release o=LP-PPA-elementary-os-stable
Pin-Priority: 1001

Tendremos que estar pendientes, en cuanto a la solución y arreglo de esta librería, que una vez se produzca, ya no nos hará falta el fichero anterior, por tanto procederemos con su borrado, actualizando el sistema ya, con total normalidad.

Si te ha gustado. Comparte en tu red social:

Guarda el enlace permanente.

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.