Plank Config en ubuntu 14.04 LTS Trusty

En un post anterior comentábamos la ausencia de herramientas gráficas para la configuración de Plank, aunque ya se disponía de alguna, como era el caso de elementary Tweaks para elementary OS o de Plank-Config.

Plank Config en ubuntu 14.04 LTS Trusty

Nos detenemos en Plank-Config y vemos un poco lo que podemos hacer con él.

Plank Configuracion

Tamaño de iconos

Iconos

Nos permite elegir, para el tamaño de los iconos del dock una serie de tamaños ya predefinidos, como es el caso de Small (Pequeño), Medium (Mediano), Large (Grande) y Extra Large (Extra Grande).

O la personalización total, eligiendo la opción Custom, para luego indicar sus dimensiones.

Modo de ocultación

Modo de ocultación

Definimos el comportamiento del dock en cuanto a su visualización, disponemos de cuatro modos:

  • Don’t hide (Sin ocultar)
  • Intelligen hide (Ocultación inteligente): Se ocultara cuando se superponga una ventana encima del dock.
  • Auto hide (Ocultación automática)
  • Hide on maximice (Ocultación sobre Maximación): Se ocultará en cuanto una ventana se encuentre maximizada.

Temas

Temas

Nos permite cambiar del tema del dock, mostrándonos para su cambio aquellos temas instalados y disponibles en el sistema.

Posición

Posicion

Podemos localizar el dock, en cualquier punto de nuestro escritorio, conforme los parámetros Left (Izquierdo), Right (Derecho), Top (Superior) y Button (Inferior).

Alineamiento

Alineamiento

De la posición donde se encuentre, la alineación que deseamos, estando disponible Left (Izquierda), Right (Derecha), Center (Centro) y Panel.

Alineamiento Completa

Panel Alineamiento

Panel Alineamiento

Cuando tengamos el Alineamiento en modo Panel, dispondremos a su vez para un alineamiento para este de Left (Izquierda), Center (Centro) y Right (Derecha).

Instalación

Lo tenemos fácil vía PPA y sólo para Trusty,

$ sudo add-apt-repository ppa:yunnxx/gnome3
$ sudo apt-get update
$ sudo apt-get install plank-config

y solo para los que tengáis Plank ya instalado, si todavía no tenéis Plank y queréis instalarlo, antes de realizar el paso anterior, sería

$ sudo add-apt-repository ppa:ricotz/docky
$ sudo apt-get update
$ sudo apt-get install plank

Tras finalizar la instalación de Plank Config, tendremos que añadir su icono en el dock, para eso tendremos que ejecutar Nautilus  e irnos a la carpeta /usr/share/applications y arrastrar el icono Plank Config.

Arrastrar Plank Config

Esta entrada fue publicada en articulo, Gnome, Gnome Shell, GNU/Linux, ubuntu, Unity y etiquetada , , , , , . Guarda el enlace permanente.

16 respuestas a Plank Config en ubuntu 14.04 LTS Trusty

  1. Yoyo dijo:

    Hey compa. buscando plank-config en guguel me ha traido aquí :P

    Pero tengo un problema en Linux Mint 17 Qiana, basada en Ubuntu 14.04

    No me funciona.

    Los siguientes paquetes tienen dependencias incumplidas:
    plank-config : Depende: libvala-0.24-0 (>= 0.16) pero no es instalable

    He buscado libvala-0.24 por la red y lo he instalado, y ya puedo instalar plank-config, pero al iniciarlo me da este error :(

    plank-config: error while loading shared libraries: libgtk-3.so.0: cannot open shared object file: No such file or directory

    Y así me hallo :(

    • yunn dijo:

      Hola Yoyo, pues efectivamente, lamentablemente Linux Mint 17 utiliza ya sus propias librerías basadas en las de Gnome 3, desde Cinnamon 2.0,

      http://www.webupd8.org/2013/10/cinnamon-20-released-becomes-entire.html

      y no en las de ubuntu que se basan completamente en las de Gnome 3, de ahí el problema. A parte de no disponer Mint la librería libvala-0.24-0 y ubuntu sí, la libgtk-3-0 si observas de que repositorio la esta cogiendo es de Qiana.

      Pues lo siento Yoyo, habrá que seguir mirando otro configurador para plank en Mint y Saludos, ;)

      • Yoyo dijo:

        Ok, grax

        Como te dije en G+ en realidad solo quería poner el dock transparente y se consigue en el archivo settings de plank elegiendo Transparent como theme. ;)

  2. ikasares dijo:

    Hola, a mi me ha pasado lo mismo que a Yoyo (pedirme libvala para la instalacion y una vez instalado con un .deb, el error de libgtk3 al arrancar), pero en Voyager, basada en Xubuntu.

    • yunn dijo:

      Hola ikasares, gracias por la info, es curioso ya que Xubuntu utiliza los mismos repositorios de ubuntu Trusty y debería de funcionar. Hay algo que se nos escapa, pensando en que algo podría haber cambiando he vuelto a instalarlo en otro equipo con ubuntu Trusty y ha funcionado con normalidad. Saludos,

  3. Fer dijo:

    Hola!! muy buen aporte, me gustaria saber como lanzarlo a inicio de aplicaciones, por mas que intento no se inicia si no lo llamo desde el lanzador

    • yunn dijo:

      Hola Fer, prueba a crear un enlace, por ejemplo:

      $ cd
      $ cd .config
      $ mkdir autostart
      $ ln -s /usr/share/applications/plank-config.desktop $HOME/.config/autostart/plank-config.desktop

      Saludos,

  4. Yoyo dijo:

    Pues ahora tengo Ubuntu 14.04 y Plank Config tampoco funciona

    Para instalarlo pide libvala-0.24, lo buscas, lo instalas, instalas plank config pero luego no abre :-/

    Pues nada, a tocar el Plank a mano.

  5. Yoyo dijo:

    Da igual, para lo único que lo quiero es para usar el Transparent, y se puede poner a mano en unos segundos, solo era cabezonería ;)

  6. karlinux dijo:

    No funciona porque solo lo hace con las librerias de 32 bits… En ubuntu y derivadas:
    sudo apt-get install libgtk-3-0:i386

  7. harianba dijo:

    Hola!!
    Saliendo del tema…me gustó el conky que usas en este post. Serías tan amable de de pasar el tip? Gracias.

  8. Pingback: Plank Settings 0.0.1 en ubuntu Trusty/Utopic | Entornos GNU/Linux

  9. Luis dijo:

    Hola yunn, gracias por el post, me ha sido de gran utilidad.

    ¿Podrías decirme qué entorno y theme de escritorio usas en estas capturas de pantalla??

    Gracias

    • yunn dijo:

      Hola Luis, bueno lo primero que hay que decir, no se si te habrás fijado en la fecha de este post, es decir 05/2014. Te lo digo porque aunque consigas el tema que ahora mismo te digo, ya no valdrá para la versión actual de ese entorno de escritorio que actualmente debe estar en 3.16 y 3.18. De cualquier manera te doy la información.

      > La distribución es ubuntu 14.04 LTS Trusty
      > El entorno de escritorio es Gnome Shell 3.10
      > Y el tema se llama Delorean-dark-3.10

      Mencionar por último que su última versión, de Delorean-dark-3.18 posiblemente no se parezca a esta.

      Un placer y saludos,

Deja un comentario