Como no actualizar a Plank 0.10 en elementary OS Freya

Revisar final post.

Pues efectivamente, has leído correctamente, como NO actualizar a Plank 0.10. Y es que después de que saliera la versión 0.9.1.1346, que se anunciaba como novedad para esa versión el nuevo efecto zoom, pues la novedad para la versión 0.10 es justo lo contrario, que desaparece el mencionado efecto zoom, fenomenal.

Como no actualizar a Plank 0.10

Si no estas conforme con perder esta funcionalidad, le tienes que indicar al sistema de alguna manera que quieres conservar la versión actual rechazando por ello cualquier intento de actualización de plank y librerias.

¿ Que hay que hacer para esto ? Pues importante conocer primeramente de donde instalaste plank, si fue por medio principalmente de la PPA de Rico Tzschicholz y a tener encueta también que repositorios estas utilizando para actualizar, si son los estables o daily de elementary OS Freya, los cuales contiene ya la mencionada versión 0.10.

De cualquier manera tendremos que crear un fichero de preferencias en el cual indicaremos que paquetes no tiene que actualizar y de que repositorios no deberá de hacerlo.

$ sudo nano /etc/apt/preferences.d/plank

Tras su edición deberemos insertar las siguientes lineas,

#PPA de Rico Tzschicholz
Package: plank libplank-common libplank-dev libplank-doc libplank0 libplank0-dbg plank-dbg
Pin: release o=LP-PPA-ricotz-docky
Pin-Priority: -10
#
#PPA Daily elementary OS
Package: plank libplank-common libplank-dev libplank-doc libplank0 libplank0-dbg plank-dbg
Pin: release o=LP-PPA-elementary-os/daily
Pin-Priority: -10
#
#PPA Stable elementary OS
Package: plank libplank-common libplank-dev libplank-doc libplank0 libplank0-dbg plank-dbg
Pin: release o=LP-PPA-elementary-os/stable
Pin-Priority: -10

tras esto procedemos a salvar el fichero.

Os comento un ejemplo, de los parámetros utilizados,

1)

Package: plank libplank-common libplank-dev libplank-doc libplank0 libplank0-dbg plank-dbg

donde indicamos los paquetes a no actualizar.

2)

Pin: release o=LP-PPA-ricotz-docky

Nombre del repositorio que contiene los paquetes mencionados anteriormente.

3)

Pin-Priority: -10

Una prioridad en negativo, indica no actualizar y por tanto conservar la que actualmente tenemos.

Ahora sí, probamos que en la actualización que hagamos no nos salgan los paquetes indicados anteriormente.

$ sudo apt-get update
$ sudo apt-get upgrade

ACLARACION

Parece ser que hay cierta confusión sobre el tema, ya que finalmente la no disponibilidad del efecto zoom, solamente se encuentra en la versión disponible en los repositorios de elementary OS Freya y no en la PPA de Rico Tzschicholz, que si esta funcionando correctamente. Por tanto si deseas dicha funcionalidad no tienes que crear al fichero de preferencias anterior y agregar dicho repositorio, actualizando a continuación,

$ sudo add-apt-repository ppa:ricotz/docky
$ sudo apt-get update
$ sudo apt-get upgrade

Si te ha gustado. Comparte en tu red social:

Guarda el enlace permanente.

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.