Tip XVII: gtk3-nocsd en BunsenLabs Helium

Posiblemente alguna vez nos hayamos preguntado, sobre la decoración de ventanas cuando hacemos uso de algún programa en Gtk3. Ya que estos utiliza decoración propia  para proporcionar homogeneidad entre las aplicaciones realizadas con estas librerías, si bien impide y anula, la decoración realizada desde el gestor de ventanas en uso, en este caso Openbox.

Tip XVII: gtk3-nocsd en BunsenLabs Helium

Parece que esta decoración mas o menos la podemos anular, si instalamos el paquete gtk3-nocsd, una recomendación que nos hacen tanto del forum como desde la pagina de temas desde Git de BunsenLabs.

csd

Este paquete por tanto esta disponible desde los repositorios de Debian 9 Stretch y de igualmanera para BunsenLabs Helium.

$ sudo apt install gtk3-nocsd

Después de la instalación del mismo, requiere un refresco total de las librerías, por lo que se recomienda, reiniciar el ordenador.

Para comprobar su funcionamiento abrimos alguna aplicación que utilicen estas librerías en mi caso utilizo Lollypop y Nautilus en Gtk 3.22, que como se muestra en la siguiente captura, no tiene ningún efecto para Lollypop, y si para Nautilus que se visualiza correctamente.

nocsd

nocsd1

Personalmente no me disgusta demasiado la decoración de Gtk3, si bien entiendo la dificultad de encontrar temas que tengan la homogeneidad correcta para Gtk3 y Openbox. :)

 

 

Esta entrada fue publicada en articulo, CrunchBang, Debian, Gnome, GNU/Linux, Openbox, temas, ubuntu y etiquetada , , , , , , , , , , , , , , . Guarda el enlace permanente.

2 respuestas a Tip XVII: gtk3-nocsd en BunsenLabs Helium

  1. Diegoto dijo:

    Buenas,

    Como siempre un gran artículo de mucha utilidad.

    Por cierto, ¿Ya tienes BL basado en Debian 9? No veo ni anuncio ni ningún sitio para descargar. ¿Como lo has conseguido?¿Cambiando los repos a stretch al BL Deuterium?

    Un saludo y felicitaciones por el gran trabajo que estas haciendo.

    • yunn dijo:

      Hola Diegoto, de momento no hay nada y la opción más fácil es ésa, simplemente cambiando los repositorios a Stretch. Te dejo este enlace del forum. Saludos,

Deja un comentario